this post was submitted on 09 Sep 2023
760 points (97.3% liked)

Programmer Humor

31251 readers
955 users here now

Post funny things about programming here! (Or just rant about your favourite programming language.)

Rules:

founded 4 years ago
MODERATORS
 
you are viewing a single comment's thread
view the rest of the comments
[–] [email protected] 246 points 10 months ago* (last edited 10 months ago) (13 children)

Many years ago I had to try to debug a memory manager written by a really talented software engineer, with an interesting take on naming things…

  • He referred to blocks of memory as “cookies”.

  • He had a temporary variable named “handy” because it was handy to have around.

  • He had a second temporary variable that referenced the first one that he called “son_of_handy”.

  • If corruption was detected in a block of memory then it would set the flag “shit_cookie_corrupt”.

  • If too many cookies were corrupt then the system would halt by calling the function “oh_shit_oh_shit_oh_shit”.

[–] [email protected] 37 points 10 months ago (5 children)

proposal to rename exit() to oh_shit_oh_shit_oh_shit()

[–] [email protected] 28 points 10 months ago (4 children)

screw_you_guys_im_going_home()

[–] [email protected] 1 points 9 months ago

screw_you_im_gonna_go_play_minecraft()

load more comments (3 replies)
load more comments (3 replies)
load more comments (10 replies)