Kimano

joined 1 year ago
[–] [email protected] 9 points 3 weeks ago

It also could be referencing something that they were better at in their prime, but may no longer be able to do due to age. Like answering running if your dad was a professional runner or something.

[–] [email protected] 4 points 3 weeks ago

They come with a big thick zip up cover, if that's the kinda thing you're looking for. I don't really remember noticing any powder on mine when I got it, but it's entirely possible I just didn't notice.

[–] [email protected] 2 points 3 weeks ago

I haven't ever weighed it so that might be a bit of an overestimate, but not by much lmao, it's ridiculously heavy

[–] [email protected] 7 points 3 weeks ago (4 children)

I also got a purple pillow on a friend's recommendation. I'm a really hot sleeper, and a side sleeper, so I need a lot of pillow and it was hard finding both of those things in one pillow for me. It's been great, I like it a lot. The main downsides are it's heavy as shit (the pillow probably weighs like 8kg, it's wild), the weird rubbery texture takes some getting used to, and the little mats they give you that go under the pillow to make it taller get bunched up if you move the pillow too much.

Other than those minor complaints, I've really loved it. It stays very cool, while still being springy and contouring.

I haven't really experimented with other pillowcases, but I have been meaning to, if anyone knows of something nice.

[–] [email protected] 3 points 1 month ago

Yeah, the annoying thing is the people who I generally have found to be the worst about stuff like this are old school Senior C developers, who still program like it's 1987 and we have to fit everything into 4K of RAM.

Fortunately there's nothing like that in my code base, I just run into stuff like that periodically when I'm digging around in other team's server code looking for something.

[–] [email protected] 20 points 1 month ago (4 children)

My personal code readability axe to grind is nested complex ternary operators.

Every now and then I'll see something like this

return (checkFormatType(currentObject.type==TYPES.static||currentObject type==TYPES.dynamic?TYPES.mutable:TYPES.immutable)?create format("MUTABLE"):getFormat(currentObject));

And I have a fucking conniption because just move that shit into a variable before the return. I get it when sometimes you just need to resolve something inline, but a huge amount of the time that ternary can be extracted to a variable before the ternary, or just rewrite the function to take multiple types and resolve it in the function.